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WOPR File Manager
WOPR File Manager is a Word 6.0 add-in that allows you to manage your document files without leaving 
Word for Windows. Using WOPR File Manager you can Open, Copy, Move, Rename, Delete and Print 
your documents all from one dialog. Additionally, you can change file attributes, make new directories, 
preview a file's contents and summary information (before you open the file), and jump to commonly used
subdirectories with a quick click of your mouse. 

The WOPR File Save As dialog allows you to quickly save your documents to commonly used directories 
with user-friendly names such as "Work Documents" instead of "C:\WinWord\Docs\Work". The WOPR 
File Save As dialog also adds the ability to create new directories just before saving a document. 

By default WOPR File Manager appears on the File menu. You can, however, assign WOPR File 
Manager to any key combination or Toolbar button. To do this, create a macro with the following text:
Sub Main
WOPRFileManager
End Sub
After creating this macro, assign the macro to any menu, key combination or Toolbar button using Word's 
Customize dialog (from the Tools menu choose Customize).

See also:
WOPR File Save As



Opening Files
WOPR File Manager is designed to give you quick access to your documents. 

Opening Files 
1. From the File menu choose WOPR File Manager.
2. Click on a Cubbyhole or use the Directories list box to change directories.

3. Select a file type from the "List Files by Type" list box to narrow your selection of files (Document or 
Text files).

4. Select a file from the File Name list box. 

When a file is selected the date, time and size is displayed below the "List Files of Type" list box. If 
the document is a Word 6.0 or 2.0 document, the document summary information is displayed. The 
list box at the bottom of the dialog displays the document's contents (the first 4K of document text). 
WOPR File Manager can preview Word 6.0 documents, Word 2.0 documents and text files.

5. Click the Open File button to open the document in Word for Windows.

Show Titles
Mark this check box and WOPR File Manager displays your Word document titles (when available) 
instead of the MS-DOS file name in the File Name list box. The document title is taken from the File 
Summary Information dialog of Word for Windows. To change the document title, open the document into 
Word and choose Summary Info from the File menu. 

The document title is displayed in a thinner font so that more text can fit left to right. You can increase the 
size of the File Name list box by marking the Keep It Simple check box. This option keeps the dialog 
simple by removing the directories and drives list boxes. To change to a different drive/directory, just click 
on the Cubbyhole name.

If your document title is less than 8 characters, File Manager will display the document title and the MS-
DOS file name in parenthesis. For example: "Letter (LETSD.DOC)". If 8 characters is too many or too 
few, you can change the AddFileNameWhenTitleLenLessThan setting in your WOPRFILE.INI file 
(WOPRFILE.INI is a preference file in your \Startup directory).
[WOPR File Open]
AddFileNameWhenTitleLenLessThan=8
File Giblets
When you select a document file name or document title from WOPR's File Name list box, information 
about the file is displayed just above the file preview list box. The first line of the file information includes 
the file's last modified date and time, as well as the file size in bytes and kilobytes. If the selected file is a
Word 2.0 or 6.0 document, the second line displays the document's summary information (File Giblets); 
Title, Author and Subject. 
If File Giblet information is not displayed when you select a file name, the file is either not a Word 
document or the document is currently open in Word for Windows or another application.

See also:
Cubbyholes



Copying and Moving Files
Using WOPR File Manager, you can copy and move files without leaving Word for Windows. 

Copying Files
1. From the File menu choose WOPR File Manager.
2. Select a file from the File Name list box and click the Copy button.

3. Choose a new drive and/or directory (the destination location) or click on a Cubbyhole location. The 
default file name is the current file name, but you can change the name by typing in the File Name 
edit box.

4. Choose the OK button to copy or copy and rename the file. 

If the file already exists in the destination directory, you will be prompted to replace the existing file.

Moving Files
1. From the File menu choose WOPR File Manager.
2. Select a file from the File Name list box and click the Move button.

3. Choose a new drive and/or directory (the destination location) or click on a Cubbyhole location. The 
default file name is the current file name, but you can change the name by typing in the File Name 
edit box.

4. Choose the OK button to move or move and rename the file. 

See also:
Deleting, Renaming and Printing Files
Opening Files



Deleting, Renaming and Printing Files
Deleting Files
1. From the File menu choose WOPR File Manager.
2. Select a file from the File Name list box and click the Delete button.

3. Word prompts you with a Yes/No message box to confirm deletion. Choose the Yes button to delete 
the file from disk.

Renaming Files
1. From the File menu choose WOPR File Manager.
2. Select a file from the File Name list box and click the Rename button.

3. Type a new file name in the New File Name edit box and click the OK button.

Printing Files
1. From the File menu choose WOPR File Manager.
2. Select a file from the File Name list box and click the Print button. If Word's background printing 

option is active, a dialog will appear briefly to indicate that the file has been prepared for background 
printing.

Clicking the Print button causes Word to lock the file. The file cannot be moved, copied, renamed or 
printed until Word lets go of the file handle. This is usually after the file has been printed, but in some 
cases it may be longer. You may need to close WOPR File Manager and any open documents to 
convince Word to release the file.

See also:
Opening Files
Copying and Moving Files



Creating Directories
The New Dir button in the WOPR File Manager dialog allows you to create a new MS-DOS directory. Use
either of the following methods:

Click the New Dir button and type the full path for the new directory. For example, "A:\DOCS".

Prior to choosing the New Dir button, change the current directory by changing the path in the Directories 
list box or click on a Cubbyhole. When you click on the New Dir button, type a valid MS-DOS directory 
name and WOPR File Manager will create the directory under the current directory. For example, if the 
current directory is C:\WINWORD and you type DOCS in the New Directory edit box, the following 
directory path will be created: 

C:\WINWORD\DOCS

A New Dir button is also available in the WOPR File Save As dialog and the functionality is exactly the 
same.

See also:
WOPR File Save As



File Attributes
The Attributes button in the WOPR File Manager dialog allows you to change the MS-DOS file attributes 
for the selected file. Select a file in the File Name list box and click the Attributes button. A dialog will 
appear allowing you to set the following MS-DOS file attributes:

Read Only
Hidden
Archive
System

Clear or mark the check boxes to set or remove a file attribute.

Note: If you select a file that is currently open in Word for Windows or another application, the Attributes 
dialog will not appear when you click the Attributes button.



Cubbyholes
What are Cubbyholes? Cubbyholes are subdirectories you commonly use to store your documents. 
Cubbyholes allow you to assign user-friendly names to your subdirectories. For example, you can create 
a Cubbyhole called "Work documents" for your D:\WinWord\Docs\Work subdirectory. To quickly jump to 
your Work subdirectory, just click on the Cubbyhole name ("Work documents") in the WOPR File Manager
dialog.

Adding Cubbyholes
1. From the File menu choose WOPR File Manager.
2. Click the Set Cubbyholes button.

3. From the Cubbyhole Directory list box, switch to a directory path you commonly use for Word 
documents.

4. In the Cubbyhole Name edit box, type a name to describe the directory path (there is a limit of 32 
characters).

5. From the Cubbyhole File Type list box select a default file type for your cubbyhole. For example, 
choose the "Document" type for a default file extension of *.DOC when you switch to your cubbyhole 
directory.

Note: If none of the defined file extension types apply to your cubbyhole, click the Set Types button to 
define a new file type for your cubbyhole (see File Types for more information on adding, renaming 
and removing File Types).

6. From the Default Save As Type list box select a default file format for your cubbyhole. For example, 
if you normally save documents to your Help Files Cubbyhole in the Rich Text Format (RTF), you can 
select Rich Text Format as the default file format. Now, when you select the Help Files Cubbyhole in 
the WOPR File Save As dialog, the file format will automatically change to Rich Text Format and the 
file extension to RTF (the default file extension for the RTF converter).

7. By default, WOPR File Save As will save your document with the file extension that Word associates 
with the file format. For example, WRI for Windows Write and DOC for Word Document. You can 
however, select a different file extension that matches your the Cubbyhole File Type set in step 5 
above. From the Extension list box, select a file extension. 

8. Click the Add button.

9. Click the Close button.

Your new Cubbyholes will appear in the main WOPR File Manager dialog as well as the WOPR File Save 
As dialog. To switch to one of your Cubbyhole directories, just click on a Cubbyhole name in the 
Cubbyholes list box.

Changing Cubbyholes
1. From the File menu choose WOPR File Manager.
2. Click the Set Cubbyholes button.

3. From the Your Cubbyholes list box, select a cubbyhole you want to change/edit.

4. Make a change to your cubbyhole name, cubbyhole directory path, or cubbyhole file type and click 
the Change button.

Removing Cubbyholes
1. From the File menu choose WOPR File Manager.
2. Click the Set Cubbyholes button.

3. From the Your Cubbyholes list box, select a cubbyhole you want to delete/remove.



4. Click the Remove button.

Keep It Simple
If you create Cubbyholes for your directory paths, you can mark the "Keep it Simple" check box in the 
main WOPR File Manager dialog. This option keeps the dialog simple by removing the directories and 
drives list boxes. To change to a different drive/directory, just click on the Cubbyhole name.

See also:
File Types
WOPR File Save As



File Types
The WOPR File Manager dialog includes a list box labeled "List Files of Type". When you select an entry 
from this list box, a file extension appears in the File Name edit box and the files listed below change to 
reflect the extension change. For example, when you select "Documents", Word changes the files listed in
the File Name list box to those that have a DOC file extension. To add, rename or remove entries from the
"List Files of Type" list box, click the Types button. 
Adding a File Type
1. From the File menu choose WOPR File Manager.
2. Click the Set Types button.

3. In the Types edit box, type a name to describe your file extension(s).

4. Click the Add button (on the left).

5. In the Extension(s) edit box, type a file extension (up to three letters). Wildcards such as ? and * are 
allowed.

6. Click the Add button (on the right).

You can add multiple file extensions for a single file type by repeating steps 5 and 6.

7. When you have finished adding file types, click the Return to WOPR File Manager button.

Renaming a File Type
1. From the File menu choose WOPR File Manager.
2. Click the Set Types button.

3. From the Types list box, select a file type you want to rename.

4. Type a new name in the Types edit box and click the Rename button.

If you want to change the file extension for a file type, select a file extension from the Extension(s) list 
box, type a new extension and click the Rename button to the right.

Removing a File Type
1. From the File menu choose WOPR File Manager.
2. Click the Set Types button.

3. From the Types list box, select a file type you want to remove.

4. Click the Remove button.

If you want to remove a file extension for a file type, select a file extension from the Extension(s) list box 
and click the Remove button to the right.
Note: The "All Files" file type cannot be changed or removed.

See also:
Cubbyholes



WOPR File Save As
The WOPR File Save As dialog allows you to quickly save your documents to one of your Cubbyholes 
and adds the ability to create new directories just before saving your documents (see Creating Directories
for information on using the New Dir button). 

Saving a New Document
1. From the File menu choose WOPR File Save As.

2. Type a name for your document in the File Name edit box. 

3. Click on a Cubbyhole name or choose a drive and/or directory.

4. Select a document format from the Save As Type list box. If you always save documents to your 
Cubbyhole using the same format, you might consider setting a "Default Save As Type" for your 
Cubbyhole. See Adding Cubbyholes for more information.

If a file format you need it not shown, click the Show All Types button.

5. By default, WOPR File Save As will save your document with the file extension that Word associates 
with the file format. For example, WRI for Windows Write and DOC for Word Document. You can 
however, select a different file extension that matches your the Cubbyhole File Type. From the 
Extension list box, select a file extension. See File Types for more information on setting File Types. 

6. Fill in the Document Information boxes at the bottom of the dialog. Note: The Show Titles option in the
WOPR File Manager dialog can be used to display document titles instead of MS-DOS file names. 
Type a Title for your documents when saving in order to take advantage of the Show Titles option.

7. Click the Save File button.

Saving an Existing Document
If you want to save a copy of an existing document to a new file name or location, follow these steps.

1. From the File menu choose WOPR File Save As.

2. If you want to save a copy of your file to a new file name, type a new name in the File Name edit box.

3. If you want to save a copy of your file to a new location, click on a Cubbyhole name or choose a new 
drive and/or directory.

4. Select a file format from the Show All Types list box. If a file format you need it not shown, click the 
Show All Types button.

5. If you want to use a file extension that matches your File Type, select a file extension from the 
Extension list box.

6. Change or add text to the Document Information boxes at the bottom of the dialog.

7. Click the Save File button.

By default WOPR File Save As appears on the File menu. You can, however, assign WOPR File Save As
to any key combination or Toolbar button. To do this, create a macro with the following text:
Sub Main
WOPRFileSaveAs
End Sub
After creating this macro, assign the macro to any menu, key combination or Toolbar button using Word's 
Customize dialog (from the Tools menu choose Customize).

See also:
Opening Files
Creating Directories
Cubbyholes



File Types



Registration Information
The WOPR File Manager add-in is just a small part of Woody's Office POWER Pack product or "WOPR" 
for short. WOPR (pronounced as whopper) includes a collection of Word for Windows macros and add-
ins such as Enveloper, Two by Four (2 X 4), TBEdit, TSS Address Book Lite, WinBreak Lite and File New. 
"WOPR 6.0" is brought to you by Pinecliffe International and can be yours for the low, low price of $49.95 
plus a $4.50 shipping and handling charge ($9.50 outside the USA). Registered users of WOPR 2.0 can 
update to WOPR 6.0 for $24.95.

Benefits for registering the WOPR product include the following:

A diskette with the latest versions of the WOPR 6.0 macros and add-ins without any pesky "nag 
screens".

Getting Started Newsletter

On-disk User's Manual.

Enveloper cheat sheet to keep envelopes from wrinkling.

Full source code for WordBasic routines.

Product Support via CompuServe (GO WOPR) or the telephone (314 965-5630).

Discounts on autographed books from WOPR contributors Woody Leonhard, Vince Chen, Lee 
Hudspeth, Scott Krueger and Jim Lee.

Offbeat WOPR goodies catalog offering unique WOPR baseball caps and our WOPR Power Putty hand
exerciser.

Discounts on other fine Word for Windows add-ons, including PRIME, WinBreak PRO, FileWare and 
others.

Our internationally famous guarantee: If WOPR ever fails to live up to your expectations -- doesn't 
matter what you expected, or why -- simply return it to us and tell us how much you paid. You will 
received a full refund, immediately. Period.

and most importantly, you'll receive our sincere thanks for helping keep WOPR alive. Our registered 
users made WOPR 6 possible. Your registration will help us continue making innovative, useful 
products for Word. We're counting on you; our families are counting on us!

To order WOPR call 1-800-659-4696 or 1-314-965-5630. If you reside outside of the United States see
the README.DOC file for registration information. We take Mastercard or Visa, and try hard to ship within
24 hours. To register by mail, send a check (in U.S. dollars, please) to:

Pinecliffe International
Advanced Support Group
11900 Grant Place
Des Peres, Missouri USA 63131

Site licenses and discounts for multiple product purchases (i.e. 10+ units) are available for WOPR 6.0. 
Call one of the above phone numbers for more information.



Troubleshooting
Û File contents do not appear in Preview window.

WOPR File Manager can preview the contents of Word 6.0 and Word 2.0 documents as well as text files. 
If the document is in another format, the contents of the file will not appear in the preview edit box 
(instead something like WC|| may appear). If the preview box is entirely blank and the file is not a 
program file, it may be that the document is opened by another application or Word for Windows. WOPR 
File Manager cannot preview, open, print, copy, move, delete... any file that is in use by Word or another 
application.

Û Cannot manipulate a file after printing

Clicking the Print button causes Word to lock the file. The file cannot be moved, copied, renamed, 
deleted, opened or printed until Word lets go of the file handle. This is usually after the file has been 
printed, but in some cases it may be longer. You may need to close WOPR File Manager and any open 
documents to convince Word to release the file.

Û Attributes button does nothing

If you select a file that is currently open in Word for Windows or another application, the Attributes dialog 
will not appear when you click the Attributes button in WOPR File Manager. In order to change a file's 
attributes, the file cannot be open in any application.

Û File Giblets are not displayed

If File Giblet information is not displayed when you select a file name in WOPR File Manager, the file is 
either not a Word document or the document is currently open in another application such as Word.

Û Files installed with WOPR File Manager

WOPRFILE.WLL This is the Add-In or program file. Place this file in your \WinWord\Startup directory or
use the File Templates dialog in Word to load the WLL file.

INTLSTR.DLL This is supporting program file for WOPR File Manager. This file should be located in 
your \Windows\System directory.

WOPRDOS.DLL This is supporting program file for WOPR File Manager. This file should be located in 
your \Windows\System directory.

CTL3D.DLL Program file used to give 3-D affects to the WOPR File Manager dialog. This file 
should be located in your \Windows\System directory.

WOPRFILE.INI Preference file for WOPR File Manager.

WOPRFILE.HLP WOPR File Manager Help file.




